Simulation error for low turbulent values of wind velocity

Provide feedback, request enhancements, and get help with wind-turbine computer-aided engineering tools.

Moderators: Bonnie.Jonkman, Jason.Jonkman

Alvaro.Olcoz
Posts: 22
Joined: Thu Nov 15, 2018 5:46 pm
Organization: Universidad Pública de Navarra
Location: Navarra

Simulation error for low turbulent values of wind velocity

Postby Alvaro.Olcoz » Tue Jun 04, 2019 3:10 pm

Dear Jason,
I am performing a batch of aeroelastic simulations under turbulent winds at several hub height average velocities, starting from 5 m/s (5 m/s, 7, 9,11...). With the lower ones, such us 5 m/s I suffer a crash in the simulations when Vx (at hub height) reaches minimum peaks, of about 2 m/s. The given error is this one:

"FAST_Solution:CalcOutputs_And_SolveForInputs:SolveOption2:AD_CalcOutput:BEMT_CalcOutput(node 9,
blade 2):Compute_UA_AirfoilCoefs:UA_CalcOutput:Mach number exceeds 1.0. Equations cannot be
evaluated."


Or this one if I set unesteady aerodynamics off:
"FAST_Solution:FAST_AdvanceStates:AD_UpdateStates:BEMT_UpdateStates(node 9, blade
2):BEMT_UnCoupledSolve:DeterminePhiBounds:There is no valid value of phi for these operating
conditions! Vx = -6.63006E-03, Vy = 5.8556, rlocal = 1.438, theta = 0.12822"


This error occurs either if I set the yaw DOF to True or to False.

From the output time series (which are attached in this post) I see that when the failure occurs the rotational speed (around 50 rpm) is too high for the incoming wind velocity (2 m/s more or less). This leads to high TSR and phi angles, and FAST crashes. Initially I have tried a Simple VS control from ServoDyn module of FAST v8 (VSContrl=1), reproducing a fixed pitch passive stall turbine as we discussed in previous topics, line blue in the figure corresponds to this implementation. I have also tried to model the torque control system with a user defined routine (VSContrl=3) (line orange in the figure) setting the generator torque to zero for wind velocities lower than the cut-in velocity (which is 3 m/s, and omega=51 rpm, more or less), and the same curve shape than in the simple VS torque control implementation but the error remains.

I hope that with your experience you could give me advice on this topic.
Thank you very much in advance,
Best regards,
Alvaro Olcoz Alonso
Student at Public University of Navarre
Attachments
torque_control.png
torque_control.png (32.11 KiB) Viewed 702 times
TEST_1_1_1_NTM.rar
(1.75 MiB) Downloaded 12 times

Jason.Jonkman
Posts: 4280
Joined: Thu Nov 03, 2005 4:38 pm
Location: Boulder, CO
Contact:

Re: Simulation error for low turbulent values of wind velocity

Postby Jason.Jonkman » Wed Jun 05, 2019 8:30 pm

Dear Alvaro,

I'm not sure exactly but it looks like some combination of high TSR and high rotor-skew angle (due to high yaw error) triggering this error regarding "no valid value of phi". There were issues in AeroDyn v15.03 within FAST v8.16 that led to this error in some cases. However, these issues have been fixed in AeroDyn v15.04 and newer, including in the release of OpenFAST v1.0 and v2. I suggest you upgrade to OpenFAST v2.0: https://nwtc.nrel.gov/OpenFAST.

Best regards,
Jason Jonkman, Ph.D.
Senior Engineer | National Wind Technology Center (NWTC)

National Renewable Energy Laboratory (NREL)
15013 Denver West Parkway | Golden, CO 80401
+1 (303) 384 – 7026 | Fax: +1 (303) 384 – 6901
nwtc.nrel.gov

Alvaro.Olcoz
Posts: 22
Joined: Thu Nov 15, 2018 5:46 pm
Organization: Universidad Pública de Navarra
Location: Navarra

Re: Simulation error for low turbulent values of wind velocity

Postby Alvaro.Olcoz » Sat Jun 08, 2019 5:29 am

Dear Jason,
Thank you one more time for your help!
Best regards


Return to “Computer-Aided Engineering Software Tools”

Who is online

Users browsing this forum: No registered users and 1 guest