Azimuth output

Provide feedback, request enhancements, and get help with wind-turbine computer-aided engineering tools.

Moderators: Bonnie.Jonkman, Jason.Jonkman

Matthias.Schmid
Posts: 7
Joined: Mon May 13, 2019 2:40 am
Organization: Institute of Turbomaschinery and Fluid Dynamics
Location: Germany

Azimuth output

Postby Matthias.Schmid » Tue May 14, 2019 3:10 am

Dear all,

I have set up a simple OpenFAST simulation and got some strange output of the azimuthal angle.
I wanted to simulate a small wind turbine at a fixed rotational speed and I set:
- The total simulation time (TMax) equal to 10 rotor revolutions,
- The time step size (DT) equal to 0.1 degree,
- The output time step size (DT_Out) equal to 1.0 degree,
- And the starting time for the output (TStart) equal to 9 rotor revolutions.

Using this setup with a constant wind speed I get only zeros as azimuth values:

Code: Select all

Time         Wind1VelX    RotSpeed     RtTSR        B1Azimuth
(s)          (m/s)        (rpm)        (-)          (deg)     
    8.0304    5.000E+00    6.725E+01    5.007E+00   -0.000E+00
    8.0328    5.000E+00    6.725E+01    5.007E+00   -0.000E+00
    8.0352    5.000E+00    6.725E+01    5.007E+00   -0.000E+00
    8.0376    5.000E+00    6.725E+01    5.007E+00   -0.000E+00
    8.0400    5.000E+00    6.725E+01    5.007E+00   -0.000E+00
    8.0424    5.000E+00    6.725E+01    5.007E+00   -0.000E+00


With a turbulent inflow, generated by TurbSim, I get the following values:

Code: Select all

Time         Wind1VelX    RotSpeed     RtTSR        B1Azimuth
(s)          (m/s)        (rpm)        (-)          (deg)     
    8.0304    7.541E+00    6.725E+01    3.697E+00   -1.348E+02
    8.0328    7.552E+00    6.725E+01    3.692E+00   -1.381E+02
    8.0352    7.563E+00    6.725E+01    3.687E+00   -1.415E+02
    8.0376    7.574E+00    6.725E+01    3.681E+00   -1.422E+02
    8.0400    7.585E+00    6.725E+01    3.677E+00   -1.391E+02
    8.0424    7.596E+00    6.725E+01    3.673E+00   -1.332E+02
    8.0448    7.607E+00    6.725E+01    3.669E+00   -1.241E+02
    8.0472    7.618E+00    6.725E+01    3.664E+00   -1.102E+02


Both results are not what I expected. Does anybody has an idea what could be wrong with my setup or is there a bug in OpenFAST?

Thank you very much for your help.

Matthias

Jason.Jonkman
Posts: 4224
Joined: Thu Nov 03, 2005 4:38 pm
Location: Boulder, CO
Contact:

Re: Azimuth output

Postby Jason.Jonkman » Tue May 14, 2019 7:45 am

Dear Matthias,

The blade azimuth angle output from AeroDyn v15 is not the rigid-body rotation of the rotor, but defines the orientation of blade relative to skewed inflow--see the following forum topic for more information: viewtopic.php?f=4&t=1680&p=8567.

The Azimuth output from ElastoDyn is likely more in line with what you expect.

Best regards,
Jason Jonkman, Ph.D.
Senior Engineer | National Wind Technology Center (NWTC)

National Renewable Energy Laboratory (NREL)
15013 Denver West Parkway | Golden, CO 80401
+1 (303) 384 – 7026 | Fax: +1 (303) 384 – 6901
nwtc.nrel.gov

Matthias.Schmid
Posts: 7
Joined: Mon May 13, 2019 2:40 am
Organization: Institute of Turbomaschinery and Fluid Dynamics
Location: Germany

Re: Azimuth output

Postby Matthias.Schmid » Wed May 15, 2019 7:46 am

Dear Jason,

thank you very much, this is what I was looking for.

Best regards,

Matthias


Return to “Computer-Aided Engineering Software Tools”

Who is online

Users browsing this forum: No registered users and 1 guest