Questions about using MLife

Provide feedback, request enhancements, and get help with wind-turbine computer-aided engineering tools.

Moderators: Bonnie.Jonkman, Jason.Jonkman

Xing.Wei
Posts: 68
Joined: Mon Jul 18, 2016 1:42 pm
Organization: University of Warwick
Location: University of Warwick, Coventry,UK

Questions about using MLife

Postby Xing.Wei » Fri Aug 26, 2016 9:08 am

Dear All

I am trying to use MLife to calculate the average equivalent loads (DEL). After I read through the MLife User’s Guide. I followed the instructions to add Source, Source\datatablepackage, and Source\Rainflow folders to the MatLab search path. Then, I changed the current directory to CertTest folder and run "mlife_certification_tests.m". However, the error appears as in the following picture.

1.PNG
1.PNG (199.49 KiB) Viewed 5381 times


I checked that I do not have Visual Studio 2010 SP1 run-time libraries installed on my computer but I have Visual Studio 2012. Whatever, I installed Redist\vcredist_x64.exe (win64). But the error is still there. Excepting asking why I have this error and how to solve this, I am wondering why we need install Redist\vcredist_x64.exe (win64) and what it is used for?

I am also wondering if running mlife_certification_tests.m is the first step before I use the MLife to calculate DEL for my own data? If I am using my own data, I am wondering if I just need to type "[Fatigue, Statistics]= mlife( settingsFile, dataDirectory, outputDirectory )" with setting all the parameters in MATLAB command window or I need to do anything else? I used MATLAB 2015a by the way.

Thank you very much!!!

Best wishes

XING WEI

Return to “Computer-Aided Engineering Software Tools”

Who is online

Users browsing this forum: No registered users and 1 guest