SOWFA Support

Provide feedback, request enhancements, and get help with wind-turbine computer-aided engineering tools.

Moderators: Bonnie.Jonkman, Jason.Jonkman

Yaakov.Nissim
Posts: 3
Joined: Wed Jun 11, 2014 6:23 am
Organization: iec
Location: Israel

Re: SOWFA Support

Postby Yaakov.Nissim » Thu Dec 17, 2015 12:01 am

Dear Users

Regarding the compilation errors of windPlantSolverFAST.C in Matthew's post and others,

Anybody know or manage to fix this bugs ?

Is there a newer version of SOWFA, an update maybe, regarding those errors ??

It was said here that FAST V8 should overcome these problems.

Can anyone Please post here an update/help regarding this issue

ThankU

Ru.Li
Posts: 2
Joined: Mon Jan 18, 2016 4:33 am
Organization: self
Location: France

SOWFA 2.0.x installation problems in OpenFoam 3.0.x

Postby Ru.Li » Wed Jan 20, 2016 2:49 am

Hi everyone,

I am trying to install SOWFA 2.0.x in a virtual machine (VMware Workstation 12). My version of OpenFoam is 3.0.x installed in geekoCFD (x86-64bit version 7.0.0). I followed README.SOWFA. When I did "Run ./Allwmake". I see the compilation errors. It seems that there are some header files missed, like GenEddyVisc.H and LESModel.H.

I figure out that the update in OpenFoam 3.0.x for the turbulence model may cause the fall of compilation. OpenFoam 3.0.0 reorganizes the .H and .C files about the Turbulence Model. We cannot find the files named GenEddyVisc anymore.

I have no idea about what to do next. Should I return to OpenFoam 2.0.x or there are other solutions? Thank you.

I should also think sincerely M. Jonkman Bonnie accepted my request to activate account in Forum.

Best Regards,

Ru Li

Han.Yi
Posts: 1
Joined: Fri Mar 06, 2015 1:43 am
Organization: University of Wyoming
Location: United States

Re: SOWFA Support

Postby Han.Yi » Thu Apr 28, 2016 4:52 pm

Hello everyone,

I am a SOWFA user (Ph.D Student in University of Wyoming). I am confusing about the "schemeBlending" section.
What does it do and why we need it in ABLTerrainSolver?

Thanks
Yi

Hugo.Olivares
Posts: 1
Joined: Tue May 17, 2016 9:40 am
Organization: Uppsala University
Location: Sweden

Re: SOWFA Support

Postby Hugo.Olivares » Tue May 17, 2016 10:21 am

Dear SOWFA users,

About the scheme blending question above, I have a problem when I try to run the ABLSolver (OpenFOAM 2.3.1 on Ubuntu 14.04). After creating the mesh, changing "buoyantPressure" for "fixedFluxPressure" in 0/p_rgh and setting initial field with setFieldsABL, I get the message:

Code: Select all

--> FOAM FATAL IO ERROR:
keyword faceSizeBlendingTable is undefined in dictionary "/home/holivares/OpenFOAM/holivares-2.3.1/run/tutorial_test2/generic.neutral/system/fvSchemes.schemeBlending"

file: /home/user/OpenFOAM/user-2.3.1/run/generic.neutral/system/fvSchemes.schemeBlending from line 76 to line 81.

    From function dictionary::lookupEntry(const word&, bool, bool) const
    in file db/dictionary/dictionary.C at line 437.

FOAM exiting


so there is a library definition for "faceSizeBlending" within fvSchemes that is missing. After looking at the syntax of the requested entry in SOWFA/applications/solvers/incompressible/windEnergy/ABLSolver/createDivSchemeBlendingField.H it seems that a matrix of 3X3 is needed. Moreover, it seems that a list for every cell is also required, which I supposed should be generated at preprocessing but I cannot exactly see which utility would that be (by looking at the runscript).

Does anybody know how to solve this?

Thank you,

Hugo

Eric.Anderson
Posts: 1
Joined: Fri Aug 19, 2016 7:28 pm
Organization: UC Davis
Location: California

Re: SOWFA and Super Controller

Postby Eric.Anderson » Mon Aug 22, 2016 10:55 am

Was "SOWFA + Super Controller" (and the custom version of OpenFOAM that went with it) ever publicly released? If not, is there any way to get a copy of it?

Thanks,
Eric

Yilei.Song
Posts: 1
Joined: Wed Oct 12, 2016 6:55 pm
Organization: Nanjing University of Aeronautics and Astronautics
Location: China

Re: SOWFA Support

Postby Yilei.Song » Sun Oct 16, 2016 7:22 am

Hello everyone,

I am new to OpenFOAM and just begin to use SOWFA. My version of OpenFoam is 2.3.1 on Ubuntu 14.04 and I downloaded the latest SOWFA from github. I have already run the precursor ABL case successfully, but I just don't know how to save the precursor data as inflow boundary conditions which will be further used in the windPlant case. I have read about the former suggestion that something can be find in https://github.com/OffWind/offwind/tree ... BL/neutral (like "makeBoundaryDataFiles.south.sh" and "makeBoundaryDataFiles.west.sh"), but I still failed to get any useful data. Following the instruction, nothing can be found in the boundaryData folder. Can anyone tell me how to run it correctly? Please give me more detailed instructions.

Thanks a lot.

Bart.Doekemeijer
Posts: 5
Joined: Mon Oct 24, 2016 7:13 am
Organization: Delft University of Technology
Location: Delft

Re: SOWFA Support

Postby Bart.Doekemeijer » Wed Oct 26, 2016 6:19 am

Hugo.Olivares wrote:Dear SOWFA users,

About the scheme blending question above, I have a problem when I try to run the ABLSolver (OpenFOAM 2.3.1 on Ubuntu 14.04). After creating the mesh, changing "buoyantPressure" for "fixedFluxPressure" in 0/p_rgh and setting initial field with setFieldsABL, I get the message:

Code: Select all

--> FOAM FATAL IO ERROR:
keyword faceSizeBlendingTable is undefined in dictionary "/home/holivares/OpenFOAM/holivares-2.3.1/run/tutorial_test2/generic.neutral/system/fvSchemes.schemeBlending"

file: /home/user/OpenFOAM/user-2.3.1/run/generic.neutral/system/fvSchemes.schemeBlending from line 76 to line 81.

    From function dictionary::lookupEntry(const word&, bool, bool) const
    in file db/dictionary/dictionary.C at line 437.

FOAM exiting


so there is a library definition for "faceSizeBlending" within fvSchemes that is missing. After looking at the syntax of the requested entry in SOWFA/applications/solvers/incompressible/windEnergy/ABLSolver/createDivSchemeBlendingField.H it seems that a matrix of 3X3 is needed. Moreover, it seems that a list for every cell is also required, which I supposed should be generated at preprocessing but I cannot exactly see which utility would that be (by looking at the runscript).

Does anybody know how to solve this?

Thank you,

Hugo


Dear Hugo,

Have you managed to resolve this issue? I am struggling with similar problems.

Cheers,
Bart

Sam.Fredriksson
Posts: 1
Joined: Mon Oct 31, 2016 6:31 am
Organization: University of Gothenburg
Location: Sweden

Re: SOWFA Support

Postby Sam.Fredriksson » Tue Nov 15, 2016 3:17 am

I am glad to hear that you managed to install SOWFA together with OF2.3 which is exactly what I am trying to do as well. I have managed to do the compilation after some addings mainly in the options files but am now running into problems during execution of the tutorial precursorABL. I have therefore a general question. Did you just compile the original downloaded version of SOWFA or did you update it first with any changes before compilation and if so with which ones?

//Sam

Zhongyou.Wu
Posts: 8
Joined: Tue Jun 28, 2016 9:11 pm
Organization: University of Texas at Dallas
Location: Richardson, Texas

Error: cannot find -lfast during installation

Postby Zhongyou.Wu » Fri Dec 30, 2016 7:51 am

Hello everyone,

I am trying to install OpenFOAM 2.0.1 on Ubuntu 14.04.5. I think I am almost done but came across this error:

/usr/bin/ld: cannot find -lfast
collect2: error: ld returned 1 exit status

I guessed the error was due to a missing libfast.so. I searched all the source files and online but could not find it. Does anyone know how to find or generate this lib file or any steps I missed during the installation? Any information is greatly appreciated. Thanks a lot in advance.

Sincerely,
Zhongyou

Ju.Gao
Posts: 1
Joined: Tue Feb 14, 2017 5:08 pm
Organization: Texas A&M University
Location: Texas

Re: Error: cannot find -lfast during installation

Postby Ju.Gao » Wed Feb 15, 2017 11:03 am

Zhongyou.Wu wrote:Hello everyone,

I am trying to install OpenFOAM 2.0.1 on Ubuntu 14.04.5. I think I am almost done but came across this error:

/usr/bin/ld: cannot find -lfast
collect2: error: ld returned 1 exit status

I guessed the error was due to a missing libfast.so. I searched all the source files and online but could not find it. Does anyone know how to find or generate this lib file or any steps I missed during the installation? Any information is greatly appreciated. Thanks a lot in advance.

Sincerely,
Zhongyou



Hi Zhongyou,

I met same problem. My Ubuntu version is 12.04 and OpenFOAM is 2.0.x. I used the SWOFA package they updated last September. My error is as below:

/usr/bin/ld: cannot find -lgfortran
/usr/bin/ld: cannot find -lfast
collect2: ld returned 1 exit status

I tried to compile the latest version of SOWFA (just update this Feb.), but more errors come out.

Have you solved this problem? If so, can you explain how you solve it? Thanks!

Giovanni.Caramia
Posts: 1
Joined: Thu May 18, 2017 7:51 am
Organization: Politecnico di Bari
Location: ITALY

Re: SOWFA Support

Postby Giovanni.Caramia » Thu May 18, 2017 9:30 am

Hi all,
I'm trying to install SOWFA but the compilation (Allwmake) ends with this error:

Code: Select all

In file included from horizontalAxisWindTurbinesALMfastv8/horizontalAxisWindTurbinesALMfastv8.C:36:0:
horizontalAxisWindTurbinesALMfastv8/horizontalAxisWindTurbinesALMfastv8.H:68:29: fatal error: FAST_cInterface.h: File or directory not found
 #include "FAST_cInterface.h"
                             ^
compilation terminated.

I have compilated FAST but in the FAST directories I did not find this file "FAST_cInterface.h" nor I found it in https://github.com/NREL/SOWFA. :shock:
Could someone tell me if and where I am going wrong? :roll:
Thank you!

Sudheer.Bhimireddy
Posts: 1
Joined: Tue Nov 14, 2017 3:18 pm
Organization: University of Texas at San Antonio
Location: Texas

Re: SOWFA Support

Postby Sudheer.Bhimireddy » Tue Nov 14, 2017 4:29 pm

Hello Everyone,

I have recently installed OpenFOAM 2.4.0 and compiled the latest SOWFA code on top of it. I am using UT Austin's TACC supercomputer Stampede2.

When I try to run the example casefiles with ABLSolver, I am getting a "Floating Point exception" error. I was able to run blockMesh, checkMesh and SetFieldsABL commands without getting any errors.

I have checked the case files and nothing seems out of line with the initial values specified. I have tried with every tutorial case and ended up with the same error. However, I was able to run cases in OpenFOAM without this error. So, I am guessing this is specific to SOWFA. When I looked online regarding this error, some suggesting issuing "unset FOAM_ SIGFPE" command. I've tried this but getting the same error.

Please help regarding this issue.

Thank you
Sudheer

Ian.Aquino
Posts: 1
Joined: Wed Nov 15, 2017 8:52 am
Organization: Old Dominion University
Location: Virginia

Create a simulation using local wind data

Postby Ian.Aquino » Wed Nov 15, 2017 10:04 am

I have successfully ran the windPlant tutorials for all the ABL conditions. I am wondering if it is possible to be able to use local wind data to create a windPlant simulation near my location? If so, what would be the best way to incorporate local data into my simulations?

Or would I just have to run simulations using averages over my set time frame?

Guillaume.Doguet
Posts: 4
Joined: Sun Mar 25, 2018 11:47 pm
Organization: Grenoble INP - ENSE3
Location: Japan

Re: SOWFA Support

Postby Guillaume.Doguet » Wed Mar 28, 2018 8:08 pm

Yilei.Song wrote:Hello everyone,

I am new to OpenFOAM and just begin to use SOWFA. My version of OpenFoam is 2.3.1 on Ubuntu 14.04 and I downloaded the latest SOWFA from github. I have already run the precursor ABL case successfully, but I just don't know how to save the precursor data as inflow boundary conditions which will be further used in the windPlant case. I have read about the former suggestion that something can be find in https://github.com/OffWind/offwind/tree ... BL/neutral (like "makeBoundaryDataFiles.south.sh" and "makeBoundaryDataFiles.west.sh"), but I still failed to get any useful data. Following the instruction, nothing can be found in the boundaryData folder. Can anyone tell me how to run it correctly? Please give me more detailed instructions.

Thanks a lot.


Hi Yilei.Song

I also want to use precursor data as inflow conditions to run example case ADM turbine or ALM turbine. But the precursor data folders haven't been added to the SOWFA directory because they were too big. Do you have any idea of how to create/get precursorDir file or others to run this tutorial cases?
For example, this is what is asked as precursor to run the example case (from runscript.solve.1):

Image

I think as you mentioned that boundaryData can be created using files such as "makeBoundaryDataFiles.south.sh" but for driving sources I have no idea how to proceed. I do not really understand actually what are these driving sources.

If you manage to solve this problem tell me, or if someone knows how to proceed please let us know.

Thanks

Eugen.Chiriac
Posts: 1
Joined: Mon Feb 19, 2018 5:25 am
Organization: von Karman Institute of Fluid Dynamics
Location: Belgium

Re: SOWFA Support

Postby Eugen.Chiriac » Thu May 03, 2018 7:59 am

Dear all,

Is the solver ABLTerrainSolver working for you?

For me, it's not working. I've tried running in debug mode and I get the following error: #6 0x000000000043b359 in main (argc=1, argv=0x7fffffffbec8) at createDivSchemeBlendingField.H:42
This is the content from the 42th line: profileTableOld = profileTable;

Since there are no examples on GitHub I don't know how to solve this issue.

I would very much appreciate your help.

Thank you,
Eugen


Return to “Computer-Aided Engineering Software Tools”

Who is online

Users browsing this forum: No registered users and 1 guest