15MW control behaviour rated wind

This forum if for discussing controls. Questions about how to implement controls in FAST are more appropriate to the CAE Tools forum.

Moderator: Bonnie.Jonkman

Peter.Veldman
Posts: 7
Joined: Tue Jan 26, 2021 5:13 am
Organization: GustoMSC
Location: The Netherlands

15MW control behaviour rated wind

Postby Peter.Veldman » Tue Jan 26, 2021 11:24 am

Dear NREL team,

I am running an openFAST simulation of the 15-MW offshore reference turbine in an under rated, rated and above rated turbulent condition (8, 10.6 and 14 m/s) generated with the use of Turbsim (V2.00.08 64-bit). For verification purposes, I fixed all translations and rotations of the floater, as well as I am ignoring structural deformation of the wind turbine tower and wind turbine blades.

When using the DISCON.dll wind turbine controller (+ DISCON-UMaineSemi.IN obtained from GitHub) with correction for the floating application, only the wind turbine responses for the rated condition (10.6 m/s) seem to behave incorrect with respect to the steady state value (see figure). The turbine responses for the under (8.0 m/s) and above rated (14 m/s) conditions behave like expected around the steady-state values.

Is there a reason for this control behavior at rated wind speed?

Best regards,

Peter Veldman
Attachments
WTG_timetrace_FAST.png
WTG_timetrace_FAST.png (59.32 KiB) Viewed 287 times

Nikhar.Abbas
Posts: 29
Joined: Wed Apr 29, 2020 7:11 pm
Organization: National Renewable Energy Lab
Location: Boulder, CO

Re: 15MW control behaviour rated wind

Postby Nikhar.Abbas » Tue Jan 26, 2021 11:54 am

Hi Peter,
This definitely is not expected behavior for ROSCO. Just to be clear, are you using the DISCON.dll available here?
https://github.com/IEAWindTask37/IEA-15 ... /ServoData

If so, this looks like it might be an outdated version of ROSCO. There were some bug fixes that should hopefully address the issues that you are seeing. Do you mind re-running your simulations with ROSCO v2.1.1 found here: https://github.com/NREL/ROSCO/tags. I suspect that this might fix your issues. If not, we can certainly do some more digging.

Best,
Nikhar

Peter.Veldman
Posts: 7
Joined: Tue Jan 26, 2021 5:13 am
Organization: GustoMSC
Location: The Netherlands

Re: 15MW control behaviour rated wind

Postby Peter.Veldman » Fri Jan 29, 2021 2:36 am

Dear Nikhar,

Thanks a lot for quick and helpful reply. The controller that I was using from https://github.com/IEAWindTask37/IEA-15-240-RWT/tree/master/OpenFAST/IEA-15-240-RWT-UMaineSemi/ServoData turned out to be outdated, indeed.

Re-running the simulations with ROSCO v2.1.1 resulted in the expected behavior.

Again, thank you very much.

Regards,

Peter Veldman


Return to “Controls”

Who is online

Users browsing this forum: No registered users and 1 guest