Windows with Visual Studio regression test

Discuss field testing of turbines and structural testing of components.

Moderator: Bonnie.Jonkman

Goyan.Leloup
Posts: 1
Joined: Mon Sep 14, 2020 7:56 am
Organization: Université Libre de Bruxelles
Location: Belgium

Windows with Visual Studio regression test

Postby Goyan.Leloup » Thu Oct 01, 2020 7:47 am

Dear all,
I just installed OpenFast on Windows 10. I tried to execute the regression tests of section 3.2.2.4.4.1. "Windows with Visual Studio regression test", as described in the manual.
Concerning step 1 : "Clone the openfast repo and initialize the testing database", it worked well (see step1 in attachment) but at step 2 :"Build The Regression Testing DISCON DLLs", I get 3 errors when building the solution on Visual Studio (see step2 in attachment).
Where do those errors come from and how can I solve them?
Kind regards.

Goyan Leloup

Jason.Jonkman
Posts: 5300
Joined: Thu Nov 03, 2005 4:38 pm
Location: Boulder, CO
Contact:

Re: Windows with Visual Studio regression test

Postby Jason.Jonkman » Thu Oct 01, 2020 1:36 pm

Dear Goyan,

I don't see that your attachments are showing up. Regardless, I would suggest posting all OpenFAST installation- and compiling-related questions into the issues section of the OpenFAST github repository: https://github.com/OpenFAST/openfast/issues. You'll get more direct support from OpenFAST developers--who may not check this forum frequenty--there. This forum better supports OpenFAST usage-related questions.

Best regards,
Jason Jonkman, Ph.D.
Senior Engineer | National Wind Technology Center (NWTC)

National Renewable Energy Laboratory (NREL)
15013 Denver West Parkway | Golden, CO 80401
+1 (303) 384 – 7026 | Fax: +1 (303) 384 – 6901
nwtc.nrel.gov


Return to “Testing”

Who is online

Users browsing this forum: No registered users and 1 guest