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Instructions for Compiling FAST using IVF for Windows® 
Excerpt from a draft of the NWTC Programming Handbook 
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National Renewable Energy Laboratory 
May 24, 2012 
 
The following instructions are provided to give users a general idea on how to compile the FAST 
code. These instructions have been developed using FAST 7.01.00a-bjj. Please note that names 
and number of source files may change in different releases; the Compile_FAST.bat script 
included in the FAST archive will contain the names of all the files required to compile the code. 

Before compiling, make sure you have downloaded all of the source files you need to compile. 
For FAST 7.01.00a-bjj, this includes FAST* AeroDyn, † NWTC Subroutine 
Library

 v13.00.01a-bjj, and 
‡

Using the Command Line 

 v1.04.01. 

FAST is currently distributed with a batch file called “Compile_FAST.bat” that will compile the 
code using IVF. We are aware that a makefile would be a better alternative, but do not currently 
have the resources to create and support it. 

Before using Compile_FAST.bat, you must modify variables in the sections labeled “set 
compiler internal variables” and “local paths.” 

Set Compiler Variables 
In the “Set Compiler Internal Variables” section, you make sure that the proper paths and 
environment variables are set for the compiler and linker. The number one reason that people 
have trouble with the Compile_FAST.bat script is that this step has not been done correctly. The 
blue text shown in Figure 1 (copied from Compile_FAST.bat) must be changed to reflect your 
compiler. 

 

                                                 
* http://wind.nrel.gov/designcodes/simulators/fast/ 
† http://wind.nrel.gov/designcodes/simulators/aerodyn/ 
‡ http://wind.nrel.gov/designcodes/miscellaneous/nwtc_subs/ 

Figure 1: The “Set Compiler Internal Variables” section of Compile_FAST.bat for FAST 
v7.01.00a-bjj. Text in blue must be changed by the user before running the script. 

REM ---------------------------------------------------------------------------- 
REM                   set compiler internal variables  
REM ---------------------------------------------------------------------------- 
REM    You can run this bat file from the IVF compiler's command prompt (and not  
REM    do anything in this section). If you choose not to run from the IVF command 
REM    prompt, you must call the compiler's script to set internal variables. 
REM    TIP: Right click on the IVF Compiler's Command Prompt shortcut, click 
REM    properties, and copy the target (without cmd.exe and/or its switches) here: 
 
CALL "C:\Program Files (x86)\Intel\ComposerXE-2011\bin\ipsxe-comp-vars.bat" ia32 vs2008 
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One way to find this command is to open the shortcut to the IVF command prompt (also called 
IVF Build Environment in some versions). You can usually find the shortcut at a location named 
something like Start > All Programs > Intel CompilerName > CommandPromptName. 
(Different versions of the compiler may have more submenus.) Right click on the shortcut and 
click “Properties.” (See Figure 2 for an example.) A window similar to Figure 3 will open. 

 

Copy the text from the Shortcut’s “Target” field and paste it in the Compile_FAST.bat script: 

C:\Windows\SysWOW64\cmd.exe /E:ON /V:ON /K ""C:\Program Files 
(x86)\Intel\ComposerXE-2011\bin\ipsxe-comp-vars.bat" ia32 vs2008" 

You will need to remove the call to cmd.exe and its switches, leaving you with the name of a 
batch file (and possibly some of its arguments): 

"C:\Program Files (x86)\Intel\ComposerXE-2011\bin\ipsxe-comp-vars.bat" ia32 vs2008 

If you do not want to call this batch file from Compile_FAST.bat, you may remove the line from 
the file. However, you must then run Compile_FAST.bat only from the compiler’s command line 

 
Figure 3: The properties window for an IVF 

command prompt shortcut 

 
Figure 2: An example of finding the IVF 

command prompt shortcut 
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window. Please refer to your compiler’s documentation about using ifort and calling it from the 
command line. 

Set Local Paths 
The second section that must be modified in Compile_FAST.bat is labeled “Local Paths.” This 
section needs to be updated with the paths to the source files you are trying to compile. The text 
that must be updated is shown in blue in Figure 4. 

 

Run The Script 
After you have modified Compile_FAST.bat, you can run it from the command line by typing 

Compile_FAST.bat 

in the directory where the batch file is stored. Figure 5 shows the screen output after a successful 
build using Intel® Composer XE 2011. Notice the title of the command window after 
Compile_FAST.bat has been run. The script that you call in the “Set Compiler Internal 
Variables” section to set the paths and environment variables for the IVF compiler also modifies 
the title of the window. If the title does not say anything about the compiler, please verify that 
you have modified Compile_FAST.bat correctly. 

Creating FAST with the User-Defined Control Options for Interfacing with GH 
Bladed-style DLLs 
If you would like to compile FAST with the user-defined control options that include the 
interface to GH Bladed-style DLLs, you can use this script to do so. After modifying 
Compile_FAST.bat as outlined above, you must also copy the FAST source files named 
UserSubs.f90 and UserVSCont_KP and rename them UserSubs_forBladedDLL.f90 and 
UserVSCont_KP_forBladedDLL.f90 respectively. In UserSubs_forBladedDLL.f90, you must 
comment out subroutines UserHSSBr and UserYawCont, and in 
UserVSCont_KP_forBladedDLL.f90, you must comment out subroutine UserVSCont. To 
compile, you type  

Compile_FAST.bat dll 

Figure 4: The “Local Paths” section of Compile_FAST.bat for FAST v7.01.00a-bjj. Text in blue 
must be changed by the user before running the script. 

REM ---------------------------------------------------------------------------- 
REM ------------------------- LOCAL PATHS -------------------------------------- 
REM ---------------------------------------------------------------------------- 
REM -- USERS WILL NEED TO EDIT THESE PATHS TO POINT TO FOLDERS ON THEIR LOCAL -- 
REM -- MACHINES.  NOTE: do not use quotation marks around the path names!!!! --- 
REM ---------------------------------------------------------------------------- 
REM NWTC_Lib_Loc is the location of the NWTC subroutine library files 
REM AeroDyn_Loc  is the location of the AeroDyn source files 
REM Wind_Loc     is the location of the AeroDyn wind inflow source files 
REM FAST_LOC     is the location of the FAST source files 
REM ---------------------------------------------------------------------------- 
 
SET NWTC_Lib_Loc=C:\Users\bjonkman\Data\DesignCodes\NWTC Library\source 
SET AeroDyn_Loc=C:\Users\bjonkman\Data\DesignCodes\AeroDyn\Source 
SET Wind_Loc=C:\Users\bjonkman\Data\DesignCodes\AeroDyn\Source\InflowWind\Source 
SET FAST_Loc=C:\Users\bjonkman\Data\DesignCodes\FAST\Source 
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at the command line. The executable file that is created will end with _DLL.exe. 

  

 
Figure 5: The command prompt window after Compile_FAST.bat has been run. 
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Using Microsoft Visual Studio 
Microsoft® Visual Studio is an integrated development environment (IDE) that provides useful 
features for editing source code, compiling, and debugging. The following instructions for 
compiling FAST have been developed using Microsoft Visual Studio 2008; the steps will be 
similar for other versions. Note that the size and location of some of the windows in Visual 
Studio may also vary based on your configuration settings. 

Open a New Project 
Open Visual Studio and create a new project of type Intel® Visual Fortran > Console 
Application. Choose the Empty Project template, and select a name and location for the project 
before clicking OK. See Figure 6. 

 

Add Source Files 
Next, you will need to add the source files for FAST and the other codes (components or 
modules) it uses. To keep the source files organized, you can create folders for each of the 
components. In the Solution Explorer window, right click on the Source Files folder under 
<project name>. Choose Add > New Folder, and a new folder named “NewFolder1” will be 
added under the Source Files folder. (See Figure 7.) Rename the folder something descriptive, 
such as “FAST” for the FAST source files. 

 

Figure 6: The New Project window in Visual Studio 
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Then right-click on the folder you have just added and choose Add > Existing Item… (Figure 
8). 

In the Add Existing Item window that opens, you must browse to the folder containing the 
source files for that component (FAST in this case). Select all of the source files that you need 
from the directory.  

 

Figure 7: Adding new folders for source files in Microsoft Visual Studio 2008. Note that the 
Soultion Explorer window may be located in another part of the screen 
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Create new folders under Source Files for each of the other components and add their source 
files to your project. When you are finished, your Solution Explorer window will look 
something like Figure 9. (Note that if you choose to use the user-defined control options for 
interfacing with a GH Bladed-style DLL in FAST v7.01.00a-bjj, your list of FAST source files 
will include BladedDLLInterface.f90, UserSubs_forBladedDLL.f90, and 
UserVSCont_KP_forBladedDLL.f90. It will not include PitchCntrl_ACH.f90, UserSubs.f90, or 
UserVSCont_KP.f90.  The file UserSubs_forBladedDLL.f90 is a copy of UserSubs.f90 with 
subroutines UserHSSBr and UserYawCont commented out. The file 
UserVSCont_KP_forBladedDLL.f90 is a copy of UserVSCont_KP with subroutine UserVSCont 
commented out.) 

 

Figure 8: Adding existing source files to a Visual Studio 2008 project. 
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Set Compiler Options 
Next, you must set the compiling options for 
the project. On the main menu, select 
Project > <project name> Properties. 
(Note: if you select an individual source file 
and then click on Project > Properties, you 
will change the properties for only that source 
file. Make sure you are changing properties 
for the entire project here.) 

A <project name> Property Pages window 
will open. See Figure 10. In the 
Configuration dropdown box at the top of 
the window, select “All Configurations” to set 
the compiler options for all configurations. 

Select Configuration Properties > Fortran 
> Data in the box on the left. In the window 
on the right, select Use Bytes as RECL = 
Unit for Unformatted Files and choose 
Yes (/assume:byterecl). (This option is 
required for InflowWind’s coherent 
structures). Because FAST v7.01.00a-bjj still 
has some unresolved issues relating to local 
variables and their initialization, you will also 
need to set Local Variable Storage to All 
Variables SAVE /Qsave, and set Initialize 
Local Saved Scalars to Zero to Yes 
(/Qzero). (Note that once we find and fix 
these issues, we will no longer compile with 
/Qsave and /Qzero.) Click OK to save your 
changes and close the window. The window 
in Figure 10 shows the project properties with 
the compiling options changed as necessary. 

 

Figure 9: The source files for FAST v7.01.00a-
bjj listed in the Visual Studio Solution Explorer 

window 
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Build the Project 
To build your project (create an executable file), you can choose from “Debug” or “Release” 
mode (or create your own settings). Debug mode is set to disable optimizations and generate 
debugging information. It will compile faster and run slower than Release mode. Release mode 
is set to optimize the code for speed. It does not generate debugging information. You can 
choose the desired configuration mode by clicking on the dropdown box on the toolbar or choose 
Build > Configuration Manager from the main menu. 

After you have picked the appropriate configuration, choose Build > Build Solution from the 
main menu.  The Output window will show your progress. (See Figure 11.) Any errors 
encountered during the build process will also appear there. 

This step creates an executable file, named by default <project location>\<configuration 
name>\<project name>.exe. If you want to change this file’s name, you can do so in the <project 
name> Property Pages window. (Select Project > <project name> Properties from the main 
menu.) The name of the executable is defined under Configuration Properties > Linker > 
General > Output File. See Figure 12. 

Note that $(OutDir) in Figure 12 refers to the Output Directory defined under Configuration 
Properties > General in the same window. (Remember that any changes you make apply to 
only the configuration that is selected at the top of this window.) 

 

Figure 10: The <project name> Property Pages window in Visual Studio with the compiling 
options changed for FAST v7.01.00a-bjj 
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Figure 12: The <project name> Property Pages window in Visual Studio, showing the location of 
the Output File. 

 

Figure 11: The Output window in Visual Studio after building FAST using the Debug 
configuration. 


